<!DOCTYPE html>
<html class='controller-contents'>
<head>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"def25c5cff","applicationID":"21817424","transactionName":"cwtcFxRXXF4ERBhSWV4QVw0SF1NdD0JSX0JDS0ELCU8=","queueTime":2,"applicationTime":156,"agent":""}</script>
<script type="text/javascript">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</script>
<script>
  var googleAnalyticsId = "UA-81764808-1";
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  
  ga('create', googleAnalyticsId, 'auto');
</script>

<link href='https://fonts.googleapis.com/css?family=Roboto:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://cdnjs.cloudflare.com/ajax/libs/selectize.js/0.8.5/css/selectize.default.css' rel='stylesheet'>
<title>CycloneReport.com  -  Clark feels connected after I-State visits</title>
<meta content='CycloneReport.com  -  Clark feels connected after I-State visits' property='og:title'>
<link rel="stylesheet" media="all" href="https://cdn.rivals.com/production/assets/application-2eada6c4ef76b32c1d573f4c7ad6fd2ed16b2c21706319015a98c50ca76b4e2e.css" />

<script src="https://cdn.rivals.com/production/assets/application-bd8e0400049933d7d82b6800a27663d3f82104735ca93ffa4c021e578eb2a73b.js"></script>
<meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="2W5qnugM22YlhlNwkpjssNxxpPADiD0X7mCsum1N5VPMEvTS9DeUO4rNTaIoRm5ttiOfN+ZCWy5b2GctaaYrmQ==" />
<script type="application/javascript">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</script>

<meta content='initial-scale=1.0, width=device-width, maximum-scale=1.0' name='viewport'>
<meta content='https://cdn.rivals.com/production/assets/favicons/browserconfig-273d00a84d0505fdc2d9beb1315850199c1ab215394a98be1a63372ca20207de.xml' name='msapplication-config'>
<meta content='#0a4ea3' name='msapplication-TileColor'>
<meta content='https://cdn.rivals.com/production/assets/favicons/mstile-144x144-bbea1de48acc36b36c4ecbc46ec3289e31950d22f6370c08529de09bfece57b8.png' name='msapplication-TileImage'>
<meta content='#ffffff' name='theme-color'>
<meta content='https://iowastate.rivals.com/news/clark-feels-connected-after-i-state-visits' property='og:url'>
<meta content='https://cdn.rivals.com/image/upload/f_auto,q_auto,t_thumbnail/f1lnrfdnjxbqq7tzp6ov' property='og:image'>
<meta content='The Cyclones have hosted a 2019 Chicagoland defensive back on three separate occasions, including this past week.' property='og:description'>
<meta content='article' property='og:type'>
<meta content='2018-04-05 10:05:35 -0500' property='article:published_time'>
<meta content='2018-04-05 10:05:54 -0500' property='article:modified_time'>
<meta content='Article' property='article:section'>
<meta content='Justin Clark' property='article:tag'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-57x57-7404e8851b384e973afdb1115390a36947dbf5fe28a232d84e5c6908cd7705d5.png' rel='apple-touch-icon' sizes='57x57'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-60x60-6648de94c2c3e41f6513ac5c0467ffd19f7c02e65a0fc936f1a9982f3ed748c8.png' rel='apple-touch-icon' sizes='60x60'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-72x72-8f5bdbc6adbf0c5fba8e0fcac9577fd4d33e68420787ee56f609e500a58b921f.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-76x76-6fe5688966b66892f842e9c4a9024cbca3c4cb1924d64c8d62a0ddbf47fc68e9.png' rel='apple-touch-icon' sizes='76x76'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-114x114-0372b897e5d8e989c1aeb7b4c620e3a3d1d7ce7406faf9ba0bfa6848c33b920a.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-120x120-783a1158ba513dae40547a7466182cab45cdd11c5d875c25c4c47b5da51c027e.png' rel='apple-touch-icon' sizes='120x120'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-144x144-8241e0d11a6d3b792f7ff1728e23e8d3d4c06a582e090d29c3dd0e3c075a9105.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-152x152-7882a3d3bb9b9b3b702c4e642b2c161e2efc0e47150051764e987199e58bd8c0.png' rel='apple-touch-icon' sizes='152x152'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-180x180-07196b8cded86c2a4bf5c14f585d72da8fb6c20c3246efc59fa27678059c9940.png' rel='apple-touch-icon' sizes='180x180'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-16x16-8f32636231ae820b22a672b74aedfff6c3106cccaeb865a002330d943f6910f4.png' rel='icon' sizes='16x16' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-32x32-c81451fd0d87890abd08b9db0a795d10339bb7c12662e9e9f3c15ac330bdaf9a.png' rel='icon' sizes='32x32' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-96x96-8df131d801eebf824632ce95b824704d0a928c3cf453c5222cbe555c87b1eb0f.png' rel='icon' sizes='96x96' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-194x194-728b6833bcd8ec9ff9fa15aba3595de5b9df51530f29547457c749719f1f0b8d.png' rel='icon' sizes='194x194' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/android-chrome-192x192-e7e88ca08f6e98bf706fceb62b57f86c338da64c83252bcc5a8b2f35fd89f191.png' rel='icon' sizes='192x192' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-6bceccff7fae6f5e335858ba74b8e9ac335e7bf9d420edf1f92ecb7b9fdee02d.ico' rel='shortcut icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/manifest-5ab6bada83e2c243aec32edcf5f419498d7897c6cfcca56ba6b1a16c7091f14d.json' rel='manifest'>
<script>
  var _sf_async_config = _sf_async_config || {};
  var subdomain = "iowastate.rivals.com";
  /** CONFIGURATION START **/
  _sf_async_config.uid = 63621; // ACCOUNT NUMBER
  _sf_async_config.domain = subdomain;
  _sf_async_config.flickerControl = false;
  _sf_async_config.useCanonical = true;
  /** CONFIGURATION END **/
  var _sf_startpt = (new Date()).getTime();
</script>
<script async src='//static.chartbeat.com/js/chartbeat_mab.js'></script>

</head>
<body class='iowastate contents-show_updated_layout' ng-app='rivals'>
<script>
  angular.module('rivals').run(function(googleAnalyticsService) {
    googleAnalyticsService.setGaClientId();
    })
</script>

<!--[if lte IE 9]><div class='browser-unsupported'>
<div class='browser-unsupported-text'>
You are using an
<strong>outdated</strong>
browser. Please
<a href='http://browsehappy.com/'>upgrade your browser</a>
to use Rivals.com
</div>
</div><![endif]-->

<style>
  @media screen and (max-width: 1023px) {
    .iowastate #programming > h1 {
      background-color: #a71930 !important; } }
  .iowastate > header .notification-link .count-container {
    background-color: #a71930 !important; }
  .iowastate > header .wrapper-container {
    background-color: #a71930 !important;
    display: block;
    position: fixed;
    top: 0px;
    width: 100%;
    z-index: 999; }
    @media screen and (min-width: 768px) {
      .iowastate > header .wrapper-container {
        border-bottom: 5px solid #e7b729 !important; } }
  .iowastate > header .invalid-email-banner {
    background-color: #a71930;
    height: 40px;
    line-height: 40px;
    position: relative;
    text-align: center;
    width: 100%;
    z-index: 998; }
    .iowastate > header .invalid-email-banner a {
      color: #fff;
      vertical-align: middle; }
    .iowastate > header .invalid-email-banner a:hover {
      color: #e7b729; }
  @media screen and (max-width: 767px) {
    .iowastate > header .mobile-header {
      background-color: #e7b729 !important;
      height: 5px;
      position: fixed;
      width: 100%;
      z-index: 50; } }
  .iowastate > header hr {
    background-color: rgba(255, 255, 255, 0.55) !important; }
  .iowastate > header .home {
    border-right: 1px solid rgba(255, 255, 255, 0.55) !important; }
  .iowastate > header .second-nav {
    background-color: white !important; }
  @media screen and (max-width: 1023px) {
    .iowastate > header .nav-row > ul,
    .iowastate > header .third-nav {
      background-color: white !important; }
    .iowastate > header .dropdown-toggle > i.fa {
      color: #a71930 !important; } }
  .iowastate > header .active {
    font-family: "Roboto", "Helvetica Neue", arial, sans-serif;
    font-weight: 500;
    color: #a71930; }
  
  .site-primary-font-color {
    color: #a71930; }
  
  .site-primary-background-color {
    background-color: #a71930; }
  
  .site-secondary-font-color {
    color: #e7b729; }
  
  .site-secondary-background-color {
    background-color: #e7b729; }
  
  :root {
    --outbrain-primary-color: #a71930;
    --outbrain-secondary-color: #e7b729; }
</style>

<header><nav ng-class='ctrl.currentUser ? "signed-in" : "signed-out"' ng-controller='NavController as ctrl' role='navigation'>
  <div class='wrapper-container'>
    <div class='wrapper logo-row'>
      <a alt="Rivals" href="//Rivals.rivals.com"><div class='rivals-logo-navbar-white'></div>
      </a>
      <a class='nav-menu-mobile' ng-click='ctrl.toggleContentNav($event)'></a>
      <a alt="Iowa State" class="school-header" href="//iowastate.rivals.com"><img src="https://res-5.cloudinary.com/rivals/image/upload/wfaivmtlachcmivkible" alt="Wfaivmtlachcmivkible" />
      </a>
      <div class='nav-right-controls'>
        <div class='subscribe-section' ng-cloak ng-if='ctrl.showSubscribe()'>
          <span>Join the Rivals community!</span>
          <a class='btn' ng-href='{{ ctrl.subscribePath }}'>Subscribe</a>
        </div>
        <rv-universal-search></rv-universal-search>
        <rv-user-dropdown current_user='ctrl.currentUser'></rv-user-dropdown>
        <rv-forums-info current_user='ctrl.currentUser' ng-if='ctrl.currentUser && (ctrl.isDesktop || ctrl.isTablet)'></rv-forums-info>
      </div>
    </div>
  </div>
  <div class='mobile-header'></div>
  <rv-header-alert class='alert-nav' scroll-min='40'></rv-header-alert>
  <hr>
  <div class='nav-row-container'>
    <div class='wrapper nav-row navbar-full' ng-cloak ng-if='!ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="//iowastate.rivals.com">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;iowastate&#39;" limit="8"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='wrapper nav-row navbar-ellipsed' ng-cloak ng-if='ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="//iowastate.rivals.com">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;iowastate&#39;" limit="4"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='nav-row invalid-email-banner' ng-cloak ng-if='ctrl.showEmailUpdateBanner'>
      <a ng-href='{{ctrl.userProfileEditPath}}'>
        Your account has an invalid email address. Please update it here.
      </a>
    </div>
  </div>
</nav>
</header>
<div class='alert-placeholder'>
<rv-header-alert></rv-header-alert>
</div>
<main class='wrapper'><script src="https://s.yimg.com/ss/rapid-3.24.js"></script>
<script>
  YAHOO.i13n.WEBWORKER_FILE = "js/rivals/analytics/rapidworker-1.2.js";
  
  var rapid = new YAHOO.i13n.Rapid({
    spaceid: 2022733104,
    ywa: {
      project_id: 10002066977754,
      document_group: 'content',
      member_id: 0
    },
    nol: 1,
    client_only: 1
  });
</script>

<script>
  var contentTitle = "Clark feels connected after I-State visits"
</script>
<meta content='summary_large_image' name='twitter:card'>
<meta content='cyclonereport' name='twitter:site'>
<meta content='Clark feels connected after I-State visits' name='twitter:title'>
<meta content='The Cyclones have hosted a 2019 Chicagoland defensive back on three separate occasions, including this past week.' name='twitter:description'>
<meta content='https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/f1lnrfdnjxbqq7tzp6ov' name='twitter:image'>
<div class='article-container-wrapper' ng-controller='ContentController' ng-init='init([{"id":1910717,"title":"RB Weston pursuing ISU offer","slug":"rb-weston-pursuing-isu-offer","kind":"free","site_id":55,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-04-04T12:11:45.459-05:00","summary":"A Missouri running back on Iowa State&#x0027;s radar made an unofficial visit over the winter and is considering a couple more.","deleted":false,"author_name":"Bill Seals","author_title":"Editor","permalink":"https://iowastate.rivals.com/news/rb-weston-pursuing-isu-offer","site_name":"CycloneReport.com","type":"Content","programming":[],"associated_links":[]},{"id":1910281,"title":"Arizona ATH says ISU is top five","slug":"arizona-ath-says-isu-is-top-five","kind":"free","site_id":55,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-04-03T10:12:50.649-05:00","summary":"Iowa State continues to commit to its Arizona recruiting effort and it is in the top five for a speedy 2019 athlete.","deleted":false,"author_name":"Bill Seals","author_title":"Editor","permalink":"https://iowastate.rivals.com/news/arizona-ath-says-isu-is-top-five","site_name":"CycloneReport.com","type":"Content","programming":[],"associated_links":[]},{"id":1909898,"title":"Cyclone offer appeals to Cali DB","slug":"cyclone-offer-appeals-to-cali-db","kind":"free","site_id":55,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-04-02T09:34:40.867-05:00","summary":"Iowa State is facing plenty of Pac 12 competition in its recruitment of three-star defensive back KJ Trujillo.","deleted":false,"author_name":"Bill Seals","author_title":"Editor","permalink":"https://iowastate.rivals.com/news/cyclone-offer-appeals-to-cali-db","site_name":"CycloneReport.com","type":"Content","programming":[],"associated_links":[]},{"id":1909142,"title":"One-on-one with new Iowa State commit Joseph Thompson","slug":"one-on-one-with-new-iowa-state-commit-joseph-thompson","kind":"premium","site_id":55,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-29T18:07:58.230-05:00","summary":"A 2019 three-star Chicago defensive back went public Thursday with his decision to commit to Iowa State.","deleted":false,"author_name":"Bill Seals","author_title":"Editor","permalink":"https://iowastate.rivals.com/news/one-on-one-with-new-iowa-state-commit-joseph-thompson","site_name":"CycloneReport.com","type":"Content","programming":[],"associated_links":[]},{"id":1908999,"title":"ISU academic side a plus for DT","slug":"isu-academic-side-a-plus-for-dt","kind":"free","site_id":55,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-29T12:00:38.640-05:00","summary":"Iowa State recently hosted a trio of teammates from a top Ohio high school program, including a priority D lineman.","deleted":false,"author_name":"Bill Seals","author_title":"Editor","permalink":"https://iowastate.rivals.com/news/isu-academic-side-a-plus-for-dt","site_name":"CycloneReport.com","type":"Content","programming":[],"associated_links":[]},{"id":1908916,"title":"Mich. ATH visits Ames in offer quest","slug":"mich-ath-visits-ames-in-offer-quest","kind":"free","site_id":55,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-29T09:59:06.983-05:00","summary":"A soph ATH from Michigan took an unofficial visit to Ames over the weekend seeking his first scholarship offer.","deleted":false,"author_name":"Bill Seals","author_title":"Editor","permalink":"https://iowastate.rivals.com/news/mich-ath-visits-ames-in-offer-quest","site_name":"CycloneReport.com","type":"Content","programming":[],"associated_links":[]},{"id":1908631,"title":"Iowa St. continues to impress 2020 DL","slug":"iowa-st-continues-to-impress-2020-dl","kind":"free","site_id":55,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-28T12:23:37.200-05:00","summary":"KCMO soph DT James Gore has camped with and now visited Iowa State. And, he thinks he&#x0027;ll camp with the Cyclones again.","deleted":false,"author_name":"Bill Seals","author_title":"Editor","permalink":"https://iowastate.rivals.com/news/iowa-st-continues-to-impress-2020-dl","site_name":"CycloneReport.com","type":"Content","programming":[],"associated_links":[]},{"id":1908262,"title":"Visit boosts Cyclones with 4-star safety","slug":"visit-boosts-cyclones-with-4-star-safety","kind":"free","site_id":55,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-27T12:05:58.552-05:00","summary":"Iowa State hosted a 4-star safety over the weekend and the Cyclones moved up in the eyes of Moses Douglass. ","deleted":false,"author_name":"Bill Seals","author_title":"Editor","permalink":"https://iowastate.rivals.com/news/visit-boosts-cyclones-with-4-star-safety","site_name":"CycloneReport.com","type":"Content","programming":[],"associated_links":[]},{"id":1908199,"title":"Soph OL learning more about I-State","slug":"soph-ol-learning-more-about-i-state","kind":"free","site_id":55,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-27T09:40:51.429-05:00","summary":"An Iowa State unofficial visit over the weekend made quite an impression on a Class of 2020 offensive lineman.","deleted":false,"author_name":"Bill Seals","author_title":"Editor","permalink":"https://iowastate.rivals.com/news/soph-ol-learning-more-about-i-state","site_name":"CycloneReport.com","type":"Content","programming":[],"associated_links":[]},{"id":1907916,"title":"Sat. announcement planned by LB Campbell","slug":"sat-announcement-planned-by-lb-campbell","kind":"free","site_id":55,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-26T11:39:58.923-05:00","summary":"Iowa State is in the final three for junior in-state LB Jack Campbell with a weekend announcement expected.","deleted":false,"author_name":"Bill Seals","author_title":"Editor","permalink":"https://iowastate.rivals.com/news/sat-announcement-planned-by-lb-campbell","site_name":"CycloneReport.com","type":"Content","programming":[],"associated_links":[]},{"id":1907860,"title":"Teammate connection could help ISU with Williams","slug":"teammate-connection-could-help-isu-with-williams","kind":"free","site_id":55,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-26T09:07:17.013-05:00","summary":"Iowa State should stay among the favorites all the way for 2020 Detroit (Mich.) receiver Rashawn Williams.","deleted":false,"author_name":"Bill Seals","author_title":"Editor","permalink":"https://iowastate.rivals.com/news/teammate-connection-could-help-isu-with-williams","site_name":"CycloneReport.com","type":"Content","programming":[],"associated_links":[]},{"id":1907670,"title":"One-on-one with new Iowa State commit Blake Peterson","slug":"one-on-one-with-new-iowa-state-commit-blake-peterson","kind":"premium","site_id":55,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-25T15:39:50.914-05:00","summary":"Iowa State won a key recruiting battle Saturday with the in-person commitment of three-star DE Blake Peterson.","deleted":false,"author_name":"Bill Seals","author_title":"Editor","permalink":"https://iowastate.rivals.com/news/one-on-one-with-new-iowa-state-commit-blake-peterson","site_name":"CycloneReport.com","type":"Content","programming":[],"associated_links":[]},{"id":1906698,"title":"Georgia CB looking to visit Iowa State","slug":"georgia-cb-looking-to-visit-iowa-state","kind":"free","site_id":55,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-22T08:05:59.781-05:00","summary":"The Cyclones are in the running with four solid Power-5 programs for a junior defensive back from Georgia.","deleted":false,"author_name":"Bill Seals","author_title":"Editor","permalink":"https://iowastate.rivals.com/news/georgia-cb-looking-to-visit-iowa-state","site_name":"CycloneReport.com","type":"Content","programming":[],"associated_links":[]},{"id":1906280,"title":"Fla. DL recalls local ISU standouts","slug":"fla-dl-recalls-local-isu-standouts","kind":"free","site_id":55,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-21T09:09:27.942-05:00","summary":"2019 defensive tackle Kennedy Roberts knows about the legacy that Tampa-area standouts have built at Iowa State.","deleted":false,"author_name":"Bill Seals","author_title":"Editor","permalink":"https://iowastate.rivals.com/news/fla-dl-recalls-local-isu-standouts","site_name":"CycloneReport.com","type":"Content","programming":[],"associated_links":[]},{"id":1906021,"title":"Mich. DE plans ISU spring game visit","slug":"mich-de-plans-isu-spring-game-visit","kind":"free","site_id":55,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-20T13:33:10.705-05:00","summary":"An unofficial visit to Ames is on tap for a three-star defensive end prospect from the Michigan high school ranks.","deleted":false,"author_name":"Bill Seals","author_title":"Editor","permalink":"https://iowastate.rivals.com/news/mich-de-plans-isu-spring-game-visit","site_name":"CycloneReport.com","type":"Content","programming":[],"associated_links":[]},{"id":1905909,"title":"Cyclones were first to offer DL","slug":"cyclones-were-first-to-offer-dl","kind":"free","site_id":55,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-20T09:18:46.381-05:00","summary":"Thirteen programs have offered a 2019 StL-area DL and he isn&#x0027;t forgetting that Iowa State led the way with his first.","deleted":false,"author_name":"Bill Seals","author_title":"Editor","permalink":"https://iowastate.rivals.com/news/cyclones-were-first-to-offer-dl","site_name":"CycloneReport.com","type":"Content","programming":[],"associated_links":[]},{"id":1905605,"title":"Third Iowa St. visit booked for Rowley","slug":"third-iowa-st-visit-booked-for-rowley","kind":"free","site_id":55,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-19T10:26:29.287-05:00","summary":"A junior lineman from the Kansas City area will make his third unofficial visit to Iowa State in the next few days.","deleted":false,"author_name":"Bill Seals","author_title":"Editor","permalink":"https://iowastate.rivals.com/news/third-iowa-st-visit-booked-for-rowley","site_name":"CycloneReport.com","type":"Content","programming":[],"associated_links":[]},{"id":1904730,"title":"I-State among favorites for Georgia RB","slug":"i-state-among-favorites-for-georgia-rb","kind":"free","site_id":55,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-16T08:25:14.134-05:00","summary":"One of the top running backs on Iowa State&#x0027;s board for the 2019 class is a three-star prospect from Georgia.","deleted":false,"author_name":"Bill Seals","author_title":"Editor","permalink":"https://iowastate.rivals.com/news/i-state-among-favorites-for-georgia-rb","site_name":"CycloneReport.com","type":"Content","programming":[],"associated_links":[]},{"id":1904729,"title":"Cal DT looking at April visit to Iowa State","slug":"cal-dt-looking-at-april-visit-to-iowa-state","kind":"free","site_id":55,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-16T08:17:16.882-05:00","summary":"It didn&#x0027;t take long for the Cyclones to take notice of a northern California defensive lineman&#x0027;s junior highlight reel.","deleted":false,"author_name":"Bill Seals","author_title":"Editor","permalink":"https://iowastate.rivals.com/news/cal-dt-looking-at-april-visit-to-iowa-state","site_name":"CycloneReport.com","type":"Content","programming":[],"associated_links":[]},{"id":1904405,"title":"In-state frosh slated to visit ISU","slug":"in-state-frosh-slated-to-visit-isu","kind":"free","site_id":55,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-15T11:06:13.355-05:00","summary":"It was a standout first season at the varsity level for a Class of 2021 recruit inside the state&#x0027;s borders.","deleted":false,"author_name":"Bill Seals","author_title":"Editor","permalink":"https://iowastate.rivals.com/news/in-state-frosh-slated-to-visit-isu","site_name":"CycloneReport.com","type":"Content","programming":[],"associated_links":[]},{"id":1904344,"title":"Cyclones in the chase for Fla. CB","slug":"cyclones-in-the-chase-for-fla-cb","kind":"free","site_id":55,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-15T07:16:53.292-05:00","summary":"A move to the defensive side of the ball is paying off for a Florida high school standout who is now up to five offers.","deleted":false,"author_name":"Bill Seals","author_title":"Editor","permalink":"https://iowastate.rivals.com/news/cyclones-in-the-chase-for-fla-cb","site_name":"CycloneReport.com","type":"Content","programming":[],"associated_links":[]},{"id":1903950,"title":"Ohio OL reels in Iowa St. offer","slug":"ohio-ol-reels-in-iowa-st-offer","kind":"free","site_id":55,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-14T09:54:27.302-05:00","summary":"Four of the five Power 5 conferences have offered an Ohio lineman after Iowa State&#x0027;s Big 12 tender last week.","deleted":false,"author_name":"Bill Seals","author_title":"Editor","permalink":"https://iowastate.rivals.com/news/ohio-ol-reels-in-iowa-st-offer","site_name":"CycloneReport.com","type":"Content","programming":[],"associated_links":[]}], nil, 55, nil, true); subdomain = &#x0027;iowastate&#x0027;; aolPlayerId = &#x0027;58e686759efa8936610b8215&#x0027;; aolCompanyId = &#x0027;58e68374c7480e728bcc385f&#x0027;'>
<div class='horizontal-ad-container'>
<div id='boxLDRB'>
<div id='tgtLDRB'></div>
</div>
</div>
<div class='article-container new'>
<div class='left-side-modules-container siderail'>
<div class='left-modules-container'>
<div class='news-list homepage-module'>
<div class='section-header news-header' style='background: #a71930'>
Ticker
</div>
<div class='news' ng-repeat='content in newsList()'>
<div class='article' ng-if='content.type === "Content"'>
<div class='forum-icon' ng-if='forumThread(content.content_type)'></div>
<a class='title' href='{{content.permalink}}' ng-class="{'indent': content.kind === 'premium'}">
<div ng-cloak>{{content.title}}</div>
</a>
<div class='byline'>
<div class='premium-icon' ng-if='content.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='link-icon' ng-if='link(content.content_type)'><?xml version="1.0" encoding="utf-8"?>
<!-- Generator: Adobe Illustrator 19.1.0, SVG Export Plug-In . SVG Version: 6.00 Build 0)  -->

<svg version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" x="0px" y="0px" viewbox="0 0 16 12.2" enable-background="new 0 0 16 12.2" xml:space="preserve">
  <path id="XMLID_228_" fill="#0A4EA3" d="M9.1,8.8C8.3,10,7,10.7,5.5,10.7c-2.4,0-4.3-1.9-4.3-4.3s1.9-4.3,4.3-4.3
      c1.4,0,2.6,0.7,3.4,1.7h1.2C9.2,2.3,7.5,1.2,5.5,1.2c-2.9,0-5.3,2.4-5.3,5.3s2.4,5.3,5.3,5.3c2,0,3.8-1.2,4.7-2.9H9.1z"></path>
  <polygon id="XMLID_229_" fill="#0A4EA3" points="16.2,6.1 13.8,3.7 13.8,6.2 5.8,6.2 5.8,7.2 13.8,7.2 13.8,8.6 	"></polygon>
</svg>
</div>
<time datetime='{{content.live_at}}' ng-cloak>
{{timeAgo(content.live_at)}}
</time>
<a class='edit-article' href='/publishing/contents/{{content.id}}/edit' ng-show='$parent.isPublisher'>Edit</a>
</div>
</div>
<div class='tweet' ng-if='content.type === "Tweet"'>
<div class='tweet-icon'></div>
<a class='title' href='{{content.tweet_url}}' target='_blank'>
<div ng-bind-html='content.text_news_feed'></div>
</a>
</div>
</div>
</div>

<div class='side-rail-meta lrec-ad' ng-if="showLRECad('leftrail-below-ticker')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
<div class='side-rail-meta lrec-ad2'>
<div class='side-rail-box'>
<div id='boxLREC2'>
<div id='tgtLREC2'></div>
</div>
</div>
</div>
<rv-custom-ad ad='{"id":247,"image_id":1903622,"url":"http://www.unitedrealestateprofessionals.com/","position":1,"site_id":55,"created_at":"2017-06-26T12:54:09.395-05:00","updated_at":"2017-06-26T12:54:09.395-05:00","image_url":"https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_ad/fyyrn8xaxwcd3jrb8jlh"}' class='ad-one'></rv-custom-ad>

<rv-homepage-forums ad-referer='https://iowastate.rivals.com/news/clark-feels-connected-after-i-state-visits' background-color='#a71930' base-api-url='https://iowastate.forums.rivals.com/' homepage='false' message-board-url='iowastate.forums.rivals.com' pub-ad='null' size='size' space-id='2022733104' subscribed-user='subscribedUser'></rv-homepage-forums>


<div class='video-ad-wrapper'>
<script async src='//c.jsrdn.com/s/cs.js?p=22546' type='text/javascript'></script>
<div class='video-container' id='ds_default_anchor'></div>
</div>
</div>
</div>
<div class='article-display-wrapper'>
<div class='new-content'>
<div class='article-header'>
<div class='pull-right'>
<rv-share-links collapsed='true' print-url='https://iowastate.rivals.com/news/clark-feels-connected-after-i-state-visits/printable' site-name='CycloneReport.com'></rv-share-links>
</div>
<span class='article-header-age' ng-cloak>{{ timeAgo('2018-04-05 10:05:35 -0500') }}</span>
<span class='article-header-sport'>football</span>
<a class='edit-article updated-article-page' href='{{editPath(subdomain)}}//publishing/contents/1911128/edit' ng-cloak ng-show='isPublisher'>Edit</a>
</div>
<h2 class='article-title'>Clark feels connected after I-State visits</h2>
<div class='header-image'></div>
<div class='author-byline'>
<div class='flex-container'>
<div class='vertical-align'>
<span>
<span class='title-sm'>
Bill Seals
&bull;
</span>
<span class='type-sm'>CycloneReport.com</span>
</span>
</div>
<div class='vertical-align link-button' ng-click='authorBio()' ng-cloak>
<div class='caret-down' ng-cloak ng-show='!expandProfile'></div>
<div class='caret-up' ng-cloak ng-show='expandProfile'></div>
</div>
</div>
<div class='expanded-content' ng-cloak ng-if='expandProfile'>
<div class='flex-container'>
<span>
<span class='title-sm'>Editor</span>
</span>
</div>
<div class='type-sm' ng-cloak ng-if='expandProfile'>

</div>
</div>
</div>
<div class='article-body-container'>
<div class='body-wrapper'>
<div class='article-body'><div class='prospect-card-article'>
<div class='prospect-profile'>
<rv-prospect-profile is-prospect-card='true' prospect-id='208990'></rv-prospect-profile>
</div>
</div>
<div class='st__content-block st__content-block--text article-text'>
<p><br></p><p>The Cyclones have hosted a Chicagoland defensive back on three separate occasions, including this past week, and the prospect said he's feeling good about the program.</p><p>Oswego three-star junior safety <b><a href="https://n.rivals.com/content/prospects/2019/justin-clark-208990">Justin Clark</a></b> said he’s been hearing from the Cyclones since his junior campaign, and that interest has steadily increased.</p><p>The 6-foot-0, 180-pound Clark, who has a 5.5 Rivals rating, also claims G5 offers from Ball State, Bowling Green, Miami (Ohio), Northern Illinois, Ohio and Toledo.</p><p>During his conversations with Campbell and other coaches on the staff, one common theme has come up and Clark said that’s his versatility.</p><p><b><a href="https://iowastate.forums.rivals.com/threads/clark-feels-connected-after-i-state-visits.43536/">For more on Clark's recruitment and how the Cyclones stack up at this stage of the process, check out a more-detailed story on the ISU Confidential message board.</a></b></p><p><br></p>
</div>
<figure class='article-image'>
<div class='blurred-image'>
<div class='background' style='background-image: url(https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/f1lnrfdnjxbqq7tzp6ov)'></div>
<img src="https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/f1lnrfdnjxbqq7tzp6ov" alt="F1lnrfdnjxbqq7tzp6ov" />
</div>
<figcaption class='image-caption'></figcaption>
<div class='image-credit'></div>
</figure>
</div>
<div class='text-center'>
<rv-share-links print-url='https://iowastate.rivals.com/news/clark-feels-connected-after-i-state-visits/printable' site-name='CycloneReport.com'></rv-share-links>
</div>
<div class='trending' ng-if='trendingArticles'>
<div class='article-subheader'>
trending
</div>
<div class='content' ng-cloak ng-repeat='article in trendingArticles'>
<a ng-href='/news/{{article.slug}}'>
<div class='title'>
{{ article.title }}
</div>
<div class='by-line'>
<div class='premium-icon' ng-if='article.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='live-at'>
{{ timeAgo(article.live_at) }}
</div>
<div class='author'>
{{ article.author_name }}
</div>
</div>
</a>
</div>
</div>
</div>
<div class='spacer'></div>
</div>
</div>

</div>
<div class='enrichment-modules-container-updated siderail'>
<rv-enrichment-module ad-two='null' enrichments='[{"active":true,"type":"Commitment","football":true,"list_id":null,"list_title":null,"position":1},{"active":true,"type":"Rivals","football":true,"list_id":null,"list_title":null,"position":2},{"active":true,"type":"Twitter","football":null,"list_id":null,"list_title":null,"position":3}]' is-super-admin='' ncaab-schedule-year='2017' ncaaf-schedule-year='2018' new-article-layout='true' site='{"id":55,"legacy_id":916,"name":"CycloneReport.com","friendly_name":"Iowa State","annual_discount":null,"subdomain":"iowastate","primary_color":"a71930","secondary_color":"e7b729","font_color":"ffffff","short_name":"iowastate","maple_ncaaf_team_id":19,"maple_ncaaf_endpoint":"ncaaf/teams/iih","maple_ncaab_team_id":277,"maple_ncaab_endpoint":"ncaab/teams/iao","maple_college_id":19,"google_analytics_id":"UA-81764808-1"}' twitter-feed='{"id":55,"site_id":55,"handle":"cyclonereport","list_name":"cyclone-report-staff","created_at":"2016-02-01T12:24:58.002-06:00","updated_at":"2016-02-02T19:11:26.504-06:00","hashtags":[],"usernames":[],"max_number":null}'></rv-enrichment-module>
</div>
<div class='sticky-footer hidden'>
<div class='text-center'>
<rv-share-links collapsed='false' print-url='https://iowastate.rivals.com/news/clark-feels-connected-after-i-state-visits/printable' site-name='CycloneReport.com'></rv-share-links>
</div>
</div>
</div>
<script>
  $(function () {
    if ('false' === 'true') {
      var comment = document.createComment("ads suppressed in development");
  
      document.body.appendChild(comment);
    }else{
      var ad_url = generateDarlaAdUrl('2022733104', 'https://iowastate.rivals.com/news/clark-feels-connected-after-i-state-visits');
  
      var script = document.createElement("script");
      script.src = ad_url;
  
      document.body.appendChild(script);
    }
  });
</script>

<script>
  var _sf_async_config = _sf_async_config || {};
  /** CONFIGURATION START **/
  var byline = document.querySelector('#byline');
  var onetimeAuthors = document.querySelector('#onetime-author');
  if (byline) { // Remove after completely transitioning to new layout (should definitely be done by Jan 1st 2018)
    var i = byline.innerText.indexOf('|');
    var author = byline.innerText.slice(0, i-1);
  } else if (onetimeAuthors) {
    // Possibly multiple authors
    var listAuthors = onetimeAuthors.innerText.split(/ ,| and/);
    var author = listAuthors.join(',');
  } else {
    var bylineNew = document.querySelector('.author-byline .title-sm');
    if (bylineNew) {
      var i = bylineNew.innerText.indexOf('•');
      var author = bylineNew.innerText.slice(0, i-1);
    }
  }
  function getAliasVariable() {
    var host = window.location.host.split('.');
    // add 'n' if it is a Site page
    if (_.include(['n', 'acceptance', 'local'], host[0].toLowerCase()) || host.length == 4) {
      if (_.include(['n'], host[0].toLowerCase())) { host.shift() } // If we are on nationals prod, drop the n subdomain from the alias (aka make it be just rivals.com)
      return host.join('.') + window.location.pathname
    } else {
      host.splice(1, 0, 'n');
      return host.join('.') + window.location.pathname
    }
  }
  _sf_async_config.section = 'article';
  _sf_async_config.authors = (byline || bylineNew || onetimeAuthors) ? author : '';
  _sf_async_config.alias = getAliasVariable();
  _sf_async_config.title = "Clark feels connected after I-State visits";
  _sf_async_config.sections = 'content,content-football,content-football-free,content-article';
  /** CONFIGURATION END **/
  function loadChartbeat() {
    window._sf_endpt = (new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src', '//static.chartbeat.com/js/chartbeat_video.js');
    document.body.appendChild(e);
  };
</script>

<div class='article-ads-footer'>
<div class='lrec-ads'>
<div class='side-rail-meta lrec-ad' ng-if="showLRECad('footer')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
<rv-custom-ad ad='{"id":247,"image_id":1903622,"url":"http://www.unitedrealestateprofessionals.com/","position":1,"site_id":55,"created_at":"2017-06-26T12:54:09.395-05:00","updated_at":"2017-06-26T12:54:09.395-05:00","image_url":"https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_ad/fyyrn8xaxwcd3jrb8jlh"}' class='ad-one'></rv-custom-ad>
</div>
<div class='OUTBRAIN' data-ob-template='Rivals.com' data-src='https://iowastate.rivals.com' data-widget-id='AR_4'></div>
<script src='https://widgets.outbrain.com/outbrain.js' type='text/javascript'></script>
</div>

</div>
</main>
<footer>
<ul class='footer-links list-inline'>
<li>
<a href='https://n.rivals.com/news/about-us'>About</a>
<a href='https://policies.yahoo.com/us/en/yahoo/privacy/products/rivals/'>Privacy Policy</a>
<a href='https://policies.yahoo.com/us/en/yahoo/ip/index.htm'>Copyright/IP Policy</a>
<a href='https://n.rivals.com/news/contact-us-5'>Contact Us</a>
<a href='/tos'>Terms of Service</a>
<a href='https://n.rivals.com/news/member-services'>Member Services</a>
</li>
</ul>
<div class='copyright-notice'>&copy; Yahoo! Inc.</div>
</footer>
</body>
<!-- Begin comScore Tag -->

<script>
  var _comscore = _comscore || [];
  _comscore.push({
    c1: "2",
    c2: "7241469",
    c5: "2022733104",
    c7: "https://iowastate.rivals.com/news/clark-feels-connected-after-i-state-visits"
  });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://s.yimg.com/lq" : "http://l.yimg.com/d") + "/lib/3pm/cs_0.2.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>

<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=7241469&c7=https%3A%2F%2Fiowastate.rivals.com%2Fnews%2Fclark-feels-connected-after-i-state-visits&c5=2022733104&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

</html>
